This forum has been archived. Please find the new support board at https://support.cubecoders.com/

AMP + McMyAdmin - Spigot BuildTool Errors.

  • 108 Views
  • Last Post 11 February 2017
d3sl91 posted this 11 February 2017

Hi All,

OS Name/Version: Windows 10 Pro

Product Name/Version: AMP 1.4.6.4

Module: McMyAdmin 1.0.0.3

Problem Description:

Spigot does not compile, Get error message when starting server:

Unable to start server.

The update manager reported a successful update, but ./Minecraft/spigot.jar is missing.

BuildTools.log:

    fatal: failed to stat 'C:/Users/Admin/AppData/Local/CubeCoders/AMP/Instances/1-McMyAdmin/Minecraft/spigotbuild/..': Permission denied
Git name not set, setting it to default value.
fatal: failed to stat 'C:/Users/Admin/AppData/Local/CubeCoders/AMP/Instances/1-McMyAdmin/Minecraft/spigotbuild/..': Permission denied
Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:561)
    at org.spigotmc.builder.Builder.main(Builder.java:162)

Steps to reproduce:

  1. Install AMP + McMyAdmin Module

  2. Set Server Type to Spigot

  3. Press "Install/Update"

  4. Attempt to Start Minecraft Server

Actions taken to resolve so far:

I'm not really sure where to start. I did check my spigotbuild folder and made sure that my current account had access and that Network Service had access as well.

2 Comments
Order By: Standard | Newest | Votes
Mike posted this 11 February 2017 - Last edited 11 February 2017

'C:/Users/Admin/AppData/Local/CubeCoders/AMP/Instances/1-McMyAdmin/Minecraft/spigotbuild/..': Permission denied

You shouldn't run AMP as administrator. It'll cause permissions issues. Check that the user running AMP has permission to read/write/modify that directory.

d3sl91 posted this 11 February 2017

'C:/Users/Admin/AppData/Local/CubeCoders/AMP/Instances/1-McMyAdmin/Minecraft/spigotbuild/..': Permission denied

You shouldn't run AMP as administrator. It'll cause permissions issues. Check that the user running AMP has permission to read/write/modify that directory.

Thanks,

The user running amp is a windows user tied to a Microsoft account - it has administrative level access to the system. Are you suggesting I create a new user on the system that does not have administrative level access to the system and installing AMP under that user account?

Yes, the user I am logged into that I installed amp under does have full access to the spigotbuild folder.

I am able to get it to work if I do not run mcmyadmin as a service. If I do not run as service, it compiles and installs just fine. However, I would like to be able to have the server start automatically when the system starts.

Any suggestions?