This forum has been archived. Please find the new support board at https://support.cubecoders.com/

Failed to grab PaperSpigot

  • 154 Views
  • Last Post 13 June 2017
  • Topic Is Solved
Dark_Hunter posted this 14 December 2016

Running AMP 1.4.1.2.

[17:58:22] [MinecraftModule:Core Debug] : Downloading from https://ci.destroystokyo.com/job/PaperSpigot/lastSuccessfulBuild/artifact/paperclip.jar, saving to ./Minecraft/paperclip.jar [17:58:22] [ModuleShared:Core Debug] : Failed Download: https://ci.destroystokyo.com/job/PaperSpigot/lastSuccessfulBuild/artifact/paperclip.jar [17:58:22] [ModuleShared:Core Error] : [0] (WebException) : Error: SecureChannelFailure (The authentication or decryption has failed.) [17:58:22] [ModuleShared:Core Error] : [1] (IOException) : The authentication or decryption has failed. [17:58:22] [ModuleShared:Core Error] : [2] (IOException) : The authentication or decryption has failed. [17:58:22] [ModuleShared:Core Error] : [3] (TlsException) : The authentication or decryption has failed.

10 Comments
Order By: Standard | Newest | Votes
Mike posted this 15 December 2016

Appears to be a Linux-only issue related to TLS 1.2 I'll take a look.

  • Liked by
  • Dark_Hunter
HexaCubist posted this 03 February 2017

Appears to be a Linux-only issue related to TLS 1.2 I'll take a look.

Hey , just a heads up this is still a problem for me.

https://thepasteb.in/p/lOh5cqOMVP2AnFJ

basmith7 posted this 31 May 2017

Did this ever get resolved? I'm still having the same issue.

Mike posted this 31 May 2017

It's half-resolved, there's a few problems to solve on Linux before the fix can be widely distributed.

basmith7 posted this 13 June 2017 - Last edited 13 June 2017

This is a 6 month old bug that breaks a main function of the app. Is there an ETA?

Mike posted this 13 June 2017

Not at the moment, it's a non-trivial issue to fix requiring extra libraries to be brought in on Linux systems.

The underlying issue is that PaperSpigots download URL requires TLS 1.2 and won't allow downgrades to 1.1 or plain HTTP, and the managed SSL impl that AMP uses doesn't support 1.2, so I have to bring in Google's Boring TLS to sort this. But getting a build of this sorted that works across different distros properly is a pain in the rear to say the least.

Dark_Hunter posted this 13 June 2017

You could do it manually for now. Just remember that Mike is a one-man team.

Mike posted this 13 June 2017

I might cheat and make it just use wget under Linux, side-step the issue entirely.

Dark_Hunter posted this 13 June 2017

I might cheat and make it just use wget under Linux, side-step the issue entirely.

Sometimes the easy cheaty fixes are right there in front of your face huh?