This forum has been archived. Please find the new support board at

Stuck on 'Starting Server...' but server actually starts (Technic Pack Official Modpacks)

  • Last Post 19 June 2017
Robert.Frost posted this 18 June 2017


Possible bug encountered when running mods from the official modpacks of (Tekkit, Hexxit etc).

Issue Description:

When creating a new instance and starting a new Minecraft server using a number of the official modpacks from Technic Pack (, the server will report in the notification area in the bottom right 'Starting Server...' - this becomes stuck approx a quarter of the way through. However, the server does actually start and people are able to connect successfully. It is as though whatever 'server is now started' signal AMP is waiting for to confirm the server is started is never actually processed.

Issue Impact:

  • The server does start and people can connect, but the AMP Minecraft GUI will still believe that the server has not yet started, so gives no options to stop/sleep or restart the server - the only available option is 'Abort'.
  • The server does seem to accurately reflect CPU and RAM, however player count does not increase when a player joins.

Test Environment:

  • Tested on latest Windows Server 2016 with all updates.
  • Downloaded latest version of AMP as of writing.
  • Tested with latest versions of Tekkit, Tekkit Lite and Hexxit modpacks from

How To Replicate:

  • Configure AMP Minecraft instance.
  • Download the Tekkit, Tekkit Lite or Hexxit server packs from
  • Set server configuration in AMP instance to the appropriate modpack from the list above (Tekkit or Tekkit Lite are both listed)
  • Extract contents of server ZIP file to Minecraft folder within AMP instance.
  • Start server.

Testing Conducted:

  • Tested on Windows Server 2016 using the latest version of Tekkit, Tekkit Lite and Hexxit modpacks.
  • Attempted to set the modpack in server config to Tekkit, Tekkit Lite.
  • Starting an official Minecraft server, everything works as expected. I suspect this issue may only affect legacy (pre 1.7 modpacks).
  • Fully reinstalled and redownloaded AMP to a separate directory on the server.
  • Ensured the NETWORK SERVICE account had full access to the AMP and AMP Instance folders.
  • The same modpacks all work normally on McMyAdmin 2.

Please let me know if I can provide any further relevant information that may assist in troubleshooting. I can provide screenshots or further console outputs if required, but it should be straightforward to replicate with the modpacks listed above from

Appreciate any feedback or assistance anyone may be able to offer.

Kind regards,


Order By: Standard | Newest | Votes
Mike posted this 18 June 2017

Which server type is selected in the server type dropdown?

Robert.Frost posted this 18 June 2017

Hi Mike,

Cheers for the quick reply.

I've tried Tekkit and Tekkit Lite. I've also tried the legacy Pre 1.7 modpack option. All results are the same.

For Hexxit specifically I tried the Pre 1.7 option and the Tekkit option. When selecting the Tekkit option I renamed the server JAR from Hexxit.jar to Tekkit.jar to get the server to start. This is how I have previously configured Hexxit servers with McMyAdmin 2 as Hexxit is not in the control panel mod list.

I also had to select the 'Skip EULA check' option for the server to start in my test cases.

Servers using vanilla Minecraft start up fine. I'm only seeing this issue on older version modpacks (Minecraft version 1.5.2 and 1.6.4 I believe from memory) from the list of official Technic Pack modpacks.

Thanks Mike,


Mike posted this 18 June 2017

Can you find the single like that says "Done!" and paste that whole line from the minecraft server log?

Robert.Frost posted this 19 June 2017

Hi Mike,

[08:19:16] [INFO] [Minecraft-Server] Done (2.058s)! For help, type "help" or "?"

I can post more of the log if required or screenshots if they are permitted.



Mike posted this 19 June 2017

okay that's why, that format isn't recognised. Can you post a few dozen lines of log samples for me to look at?

Robert.Frost posted this 19 June 2017

Sure, I pulled these logs directly from the AMP log files rather than AMP server GUI console:



Robert.Frost posted this 19 June 2017

Hi Mike/anyone else reading who is also experiencing this issue,

So I managed to find a workaround for this until a fix is brought into a future release.

The issue appears to be with log parsing of legacy Minecraft versions. It appears that AMP detects the following line in this specific format as an indicator that the server has started:

[%TIME%] [Server thread/INFO]: Done (%TIME%)! For help, type "help" or "?"

Legacy clients send this log output in the following format:

%DATE% %TIME% [INFO] [%HOSTNAME%] Done (%TIME%)! For help, type "help" or "?"

To make AMP behave like the server is started, just type the following line at the server console:

/say [14:08:20] [Server thread/INFO]: Done (36.917s)! For help, type "help" or "?"

AMP will parse this line as though the server has sent it in the non-legacy format, and all normal server options will be available.

It unfortunately still doesn't reflect when a player has joined in the users count on the status screen, but I suspect this may also be down to legacy log file parsing.